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How to make a PDF read only or not editable
in Blog, Document Security, DRM, PDF Security





How to save, create or make a PDF read only or not editable
Why creating read only PDF files using PDF password protection is pointless.  Loads of apps and online solutions claim to make a PDF uneditable, but what they don’t tell you is how simple it is to remove the read-only restrictions.  Here we cover two of the most popular solutions, why they provide zero protection against modification, and how to make a PDF document read only permanently and save fillable PDFs as read-only to prevent editing, copying & printing.



  



   Why save a PDF as read only or make it non editable?






Once you have finished creating a PDF document or converting it from a Google Doc to PDF, it’s important to protect it from any unauthorized changes.  For businesses, this may also include the options to prevent copying and pasting of content, and disable printing.  Particularly crucial for users however is when they have filled in a form PDF and wish to send it back without any modifications along the way.  To achieve this, you need to know how to save a PDF as read only or make it non editable.
As we’ll explain though, not all methods to save PDFs in a read-only format are equal since password restricted PDFs are easily bypassed enabling users to edit a read only PDF.
  



   How to edit a read only PDF
When you lock or encrypt a PDF using Adobe Acrobat and add security settings to restrict editing and copying you might expect it to be secure.  However, as we explain in our blog on How secure is Adobe PDF encryption, this is not the case.
Because permissions do not use encryption, users can easily bypass or remove restrictions and change the PDF from read only to editable.  This is true for all solutions that protect PDF files using passwords – they all use Adobe’s security handler, and are completely useless.
You can change a PDF from read only to make it editable again by:
	Opening it in a PDF reader that does not support the restrictions – Mac Preview, Google Docs, etc.
	Converting the PDF to a different file format, opening it in that app and saving as PDF.
	Uploading it to any free PDF password removal site.

To add actual security to prevent editing, see How to make a PDF not editable permanently.


  



  Why making a PDF read only using Adobe is pointless






You can make a PDF read only using Acrobat or any other PDF password protection system but it completely useless – it provides NO protection.  Why?  Users can easily edit a read only PDF by removing the restrictions.
Typically, saving a PDF as read only or creating read only PDF files, involves encrypting the document and entering two passwords:
	Document open password
This is used to protect the document from being viewed by unauthorized users.  You have to give this password to those users that you want to share the PDF with.

	Permissions password
This is used to protect the permissions or restrictions you have added to the PDF such as stopping editing, copying and printing (i.e. making it a read only document that is not editable).
However, encryption is not used to enforce restrictions, making it trivial for users to bypass or remove.


  



  Removing PDF restrictions – How to change a PDF from read only






Adobe Acrobat is the most popular software that uses this security method, but all PDF password protection products use the same system.  The problem?  Due to flaws in the Adobe Standard Security handler, it’s trivial to bypass or remove the permissions password and therefore change the PDF from read only to editable.
Just Google ‘PDF password remover’ to see the numerous free online tools available that can instantly remove PDF restrictions.  A couple of examples from the hundreds available are:
	Remove PDF Restrictions
	Unlock PDF






How to make a PDF not read only using PDF Convert Online
Some systems don’t even obey these restrictions to begin with, which is why users can edit a read only PDF without having to enter a password using various PDF editors such as Mac Preview and Google Docs.
Another simple workaround is converting the non editable PDF to another file format such as Word, and then saving it as PDF.
Setting an open password helps with this, as anybody looking to modify the document will first need the password to view the document.  However, as you need to provide the password to the recipient for them to read the document, you have to trust that they won’t change the PDF from read only.  You also need to find a secure way of giving recipient’s the password to open the document, such as sending it using a secure email system that encrypts message content.
Essentially then, you’re only protected from malicious parties that may intercept the document at some point during its use.  But if they can’t open the PDF then they can’t edit it either.
Removing read-only permissions
Because read-only permssions are so simple to remove, we do not recommend using Adobe PDF security to save any sensitive or business documents as read-only.  You should only do so if you have a high degree of trust in the recipient, and acknowledge that they can edit a read only PDF.


  



  How to make a PDF read only with Adobe Acrobat Pro
If you’re aware of the risks of Adobe PDF (i.e. it is completely useless for restricting use of PDF files) but still want to know how to save a PDF as read-only with Adobe, read on:
	Launch Adobe Acrobat DC Pro and press File > Open. Browse to your PDF document and double-click it to open it in Acrobat.






	Select “Protect” in the right sidebar.






	Click “Protect Using Password” in the top bar.






	Select the “Editing” option, enter a secure password, and press “Apply”.






	Select “File > Save As…” and save your PDF.







Be aware that your changes won’t apply until you save the document.  For additional protection, you may also want to enable the document open password in the “Advanced Options > Security Properties” menu.You should also be aware that recipients will still be able to fill form fields using this method.  We’ll show you how to address that below.


  



  How to save a fillable PDF as read only with Adobe Acrobat Pro
As mentioned, a form-fillable PDF needs some additional modification to its permissions to be made read-only.  Don’t let that fool you, however.  These permissions can still be easily bypassed by password cracking tools, PDF readers that don’t respect Adobe’s security, or using OCR with a PDF editor to make them editable again.
If you’re willing to accept those limitations, here’s how you can use Adobe Acrobat to apply the permissions:
	Launch Adobe Acrobat DC Pro and press File > Open.  Browse to your PDF document and double-click it to open it in Acrobat.






	Select “Protect” in the right sidebar.






	Select “Advanced Options > Security Properties”.






	Click “Change Settings…”.






	Tick “Restrict editing and printing of the document” and set “Changes Allowed” to “None”.






	Type your permissions password and (optionally) open password.







Remember that the open password will provide you with a bit more protection against anyone who may intercept your document.Press “OK”, re-enter the passwords, and press “OK” again to save the changes.

	Save the read only version of the PDF using the File > Save As option.






	Open and test the read-only form.







  



   How to make a PDF read-only online
If you don’t have an Adobe Acrobat license and can’t justify the cost, an online tool such as Sejda will produce a similar result.  With it, you can “flatten” your PDF so that it’s an image, rather than text.
Theoretically, this will make it non-editable, so nobody can edit your document.  In practice, however, any competent PDF editing tool such as Adobe or Foxit can convert the image back to text using OCR character recognition.  Adobe will even deliver an automatic OCR prompt when a PDF with an image is opened.
Here’s how you make a PDF read-only online using Sejda:
	Go to the Sejda website and press “Upload PDF files”.






	Select your PDF file in the browse window and press “Open”.






	Choose “Flatten everything” or “Flatten only form fields” and press “Flatten PDF”.





The “Flatten everything” option will turn everything in the document into an image, while “Flatten only form fields” will make it so only the fields can no longer be edited.

	Press the “Download” button to retrieve your read-only PDF.







After opening the PDF, you’ll notice that you can no longer change it with your PDF editing software.  However, after using an OCR tool to convert it back to an editable PDF (most PDF readers support this functionality) it will be immediately and seamlessly editable again.

  



  How to make a PDF not editable or read only permanently






For comprehensive, secure document protection that prevents PDF files from being edited, copied and printed, you’ll need PDF DRM encryption software like Locklizard.
Locklizard does not use outdated password security or complex certificates, but instead uses a license-based system with secure and transparent key management – there are no passwords or certificates to create, distribute, manage or remove.
Locklizard encrypts and converts PDF files to read only, making them permanently non-editable, and enables you to add DRM controls to prevent sharing.  Document permissions are part of the protected PDF file, and encrypted PDFs can only be viewed using Locklizard’s secure PDF viewer.  This makes it very difficult to bypass and is also resilient against OCR recognition.
  



  Creating read only PDF files in Safeguard PDF Security






Documents protected by Safeguard Secure PDF Writer are not editable by default.  They cannot be:
	edited
	printed
	screen grabbed using screenshot apps
	copied and pasted
	saved to unprotected files
	opened in a PDF editor to remove watermarks
	shared – PDF files are locked to authorized users’ devices and won’t open if copied to a different device

  



  How to save a PDF as read only
The process to create a read only PDF is very simple and the same for both PDF forms (or fillable PDFs) and regular PDF files.  Here’s how to convert a PDF to read-only with Locklizard:
	With Safeguard Writer installed, right-click on your PDF and select “Make secure PDF”.






	Choose the DRM controls you want to enforce.





Switch between the tabs at the top of Safeguard Writer and select the DRM controls you’d like to apply to the document.  Pay particular attention to the anti-screenshotting and printing controls (these are enabled by default), as these provide another layer of protection to stop users from making copies.

	Press the “Publish” button at the bottom of the dialog to protect the PDF file.
	Open your Safeguard administration system and log in.






	Open the “Customers” tab and press “Add” in the sidebar.






	Enter the user information and click on the “Set Document Access” link in the “Manage Access” section.






	Select your document and press “OK”.






	Press the “Add” button on the customer account.Keep the “Email license” checkbox checked to have the license file emailed to the user’s email address that you have entered.  The user will be sent an email with their license key and instructions on how to download the secure PDF viewer software.
Once the user activates the license in the secure PDF viewer application, they’ll be able to read, but not edit or copy your PDF.


  



  What’s the best way to save or make a PDF read only?






There are a few different methods to save or make a PDF non editable, non modifiable, or uneditable, but not all of them are equal.
	Password protection is useless
Protection that is applied when creating password protected read only PDF files does not work.  The non-editing protections (PDF permissions to prevent editing or printing) built into Adobe Acrobat and similar PDF editors or apps (both online solutions and installed software), have long been bypassable via a wide variety of methods, and it is simple for users to change a PDF from read only to editable.

	Converting to images is not effective
Software or solutions that flatten PDF files into images to make them not editable are not foolproof.  Users can change the PDF from read only by using the OCR character recognition built into most PDF readers to convert back to an editable document.

	Browser viewers cannot prevent editing
Data rooms, online collaboration tools, and other online solutions that claim to make PDFs non editable in the browser, use weak security (JavaScript) to enforce read only mode.  Users can easily bypass this protection – see How secure is Google Docs as an example.

	Online solutions are not safe
Making a PDF read only online exposes your unprotected documents to a third-party and potential compromise on a cloud server.  Online solutions should therefore not be used for important, sensitive, or confidential business documents.

	Forms need effective encryption and controls
To make a PDF form uneditable (prevent form fields from being changed or altered) you have to encrypt it and enforce read only controls.  To do this, see How to lock a PDF form – users can only fill forms in if allowed and cannot edit form fields.

	To make a PDF permanently not editable use DRM
For read only protection that is permanent, you should us PDF DRM software like Locklizard that uses encryption without passwords, digital rights management controls, and a secure viewer to enforce restrictions and prevent removal.


Locklizard enables you to make PDF files not editable or read only and control use:





	Prevent changes – restrict PDF editing and modifying
	Stop copying and copy/paste
	Disable PDF printing or enable secure prints
	Stop screenshots by preventing the use of screen grabbing software
	Expire PDF files automatically on a set date, after a number of days, opens or prints
	Lock PDF files to devices to prevent sharing, and locations to control geographic access
	Prevent saving to unprotected formats
	Add dynamic watermarks that are cannot be removed
	Secure PDF forms – stop form fields from being changed and form data altered after submission
	Track PDF opens and prints
	Revoke access at any time

Locklizard provide both installed and online viewers (for viewing read-only PDFs in the browser), so you have full control and flexibility over how your documents are used both online and offline.
With a wide range of document security controls and the ability to integrate with existing workflows via APIs, Locklizard ensures that documents permissions or restrictions cannot be removed, and documents can only be opened by those with express permission.
If you want to make a PDF read only permanently and ensure that your PDF documents cannot be shared, copied, printed or edited then take a free 15 day trial of our PDF DRM software.
  



   FAQs





What is a read-only PDF file?
A read-only PDF is one that cannot be edited or altered.  While Adobe enables you to create a read-only PDF using passwords, the security method used is weak – the permission password can be bypassed using Mac Preview, Google Docs, etc. or removed in seconds using free online password removal tools.  Making a PDF not editable using Adobe Acrobat password protection or similar app is therefore useless since users can remove the editing restrictions instantly.
Can you make a PDF uneditable or non editable online?
No.  While there are many free tools that claim to make a PDF non editable or a PDF read-only online, they just use Adobe permissions, which are trivial to remove.  Solutions that convert PDFs to images are equally useless since users can OCR them back to editable files.
If you want effective PDF  document protection,  you need to use PDF DRM software such as Locklizard Safeguard.
How do I make a PDF form non-fillable?
Just like its editing permissions, Adobe PDF form protection is easily removed.  While you can flatten a fillable PDF into an image to prevent form field editing, a user can easily add a text box over that image to add or change text.
Locklizard Safeguard offers enhanced protection – users cannot edit form fields and they can only fill forms in if allowed.  Fillable PDF form content is protected from being copied, edited, inserted, or screen grabbed.
Does Locklizard make a PDF non editable on Mac?
Yes, our read-only protected PDFs, which can only be opened with our secure Viewers, support the following operating systems – Windows, Mac, iOS and Android.  Users can also view documents online on the MacOS (in their browser) using our secure Web Viewer.
Does Locklizard prevent Save as and copy paste?
Yes, we prevent save as, converting to other file formats, copy paste, and screenshots, since these are all simple methods to bypass document permissions.  With Locklizard, a read-only PDF file cannot be opened by unauthorized users, and authorized users are restricted in how they can use it.
How do you change a PDF from read only?
If it was protected with Adobe then all of these methods remove change a PDF from read only and make it editable:
	Upload it to any PDF password removal site or use password cracking software.
	Open it in a PDF reader that does not support the read-only restrictions – Mac Preview, Google Docs, etc.
	Convert it to a different file format, open it in that application and then save as PDF.

Locklizard editing controls cannot be removed.  If you want an editable copy of a document, you will have to ask the owner for the original, unprotected version.
How do you make an editable PDF non editable with Adobe?
You can’t – while you can add editing restrictions to a PDF they are ignored by multiple PDF readers, and can be instantly removed using free online services or converting to a different file format and back again.
Can you make a word doc read-only?
You can make a Word document read-only using its inbuilt tools, but these only protect against accidental editing.  Users can easily make Word editable again.  For serious protection against misuse, it’s best to use a PDF DRM solution.  The simplest way is to convert Word to PDF and then make the document non-editable using Safeguard PDF DRM software.
How can I make a PDF read-only or non-editable using passwords?
You can’t.  The permissions to prevent editing can be instantly removed using free online tools, or bypassed using Mac Preview or other PDF readers that do not honor the read-only restrictions.
A password protected PDF that is saved as read-only is therefore completely useless.
How can I make a PDF file read-only and prevent editing, copying, and printing?
To make a PDF file read-only and prevent editing, copying, and printing, you have to use PDF DRM software.  This will restrict editing and prevent sharing, modifications or copying of the content.
While you can use Adobe Acrobat or similar software to made a PDF read-only using passwords, the protection is simple to remove.
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