# Table of Contents

## CHAPTER 1: INSTALLATION & REGISTRATION ................................................. 4

1.1 INTRODUCTION ....................................................................................... 4

1.2 INSTALLATION PRE-REQUISITES ............................................................... 4

1.3 INSTALLING THE VIEWER ........................................................................ 5

   1.3.1 Firewall messages displayed during installation ......................................... 8

1.4 INSTALLING THE VIEWER IN CORPORATE ENVIRONMENTS .................... 9

   1.4.1 Silent (remote) Installation ....................................................................... 9

   1.4.2 License File Registration (silent mode) ..................................................... 10

   1.4.3 MSI Package ......................................................................................... 11

   1.4.4 Disabling Automatic Updates .................................................................. 11

1.5 MANAGING PROXY SETTINGS ................................................................. 12

   1.5.1 Automatic configuration script ................................................................. 13

   1.5.2 Proxy server manual entry settings ......................................................... 14

   1.5.3 Proxy server installation settings ............................................................. 15

1.6 REGISTERING THE VIEWER LICENSE ..................................................... 16

   1.6.1 Immediate Registration ......................................................................... 17

   1.6.2 Save license file and then Register ........................................................ 17

   1.6.3 Zipped license files and registration ....................................................... 17

   1.6.4 Web based email systems and registration ............................................. 18

   1.6.5 Successful Registration ......................................................................... 18

   1.6.6 Registration issues and firewalls ........................................................... 19

   1.6.7 Firewall messages displayed during registration ..................................... 19

   1.6.8 Registering with a publisher more than once ....................................... 20

   1.6.9 Registering with different publishers .................................................... 20

   1.6.10 Messages displayed if you have not registered .................................... 21

## CHAPTER 2: VIEWING PROTECTED PDF FILES ......................................... 22

2.1 FIREWALL / ANTI-SPYWARE MESSAGES DISPLAYED WHEN VIEWING DOCUMENTS ........ 23

2.2 VIEWER CONTROLS .................................................................................. 24

   2.2.1 Searching for text .................................................................................. 24

   2.2.2 Page up / down controls ........................................................................ 25

   2.2.3 Document display size (zoom) ................................................................ 26

   2.2.4 Navigation buttons ................................................................................ 26

   2.2.5 Scrolling options ................................................................................... 26

   2.2.6 Viewing multiple pages (book format) ................................................. 27

   2.2.7 Menu bar display .................................................................................. 27

   2.2.8 Full screen mode ................................................................................... 27

   2.2.9 Printing Controls ................................................................................... 28

   2.2.10 Opening Documents at last viewed page ............................................ 30

   2.2.11 Saving Settings .................................................................................... 30

2.3 FILE SIZES SUPPORTED ........................................................................... 31

2.4 PROGRAM UPDATES ............................................................................... 31
2.5 DOCUMENT CONTROLS ................................................................. 32

CHAPTER 3:  USB SECURE VIEWER ................................................... 34
  3.1.1 Opening Secure Documents ..................................................... 34
  3.1.2 Proxy Settings ........................................................................ 35
  3.1.3 Keystore Password Protection .................................................. 35
  3.1.4 Remove Keystore ..................................................................... 36
  3.1.5 USB ID .................................................................................... 36
  3.1.6 Program Updates ..................................................................... 37

CHAPTER 4:  TROUBLESHOOTING ....................................................... 38
  4.1 INSTALLATION ......................................................................... 38
  4.1.1 When I go to install the viewer by double-clicking on the exe file, it tells me the file is corrupted ................................................................. 38
  4.2 REGISTRATION ........................................................................ 39
  4.2.1 Error Message "We cannot connect to the license server by Internet. Please check that you are connected, or that a firewall is not stopping this connection." ................................................. 39
  4.2.2 When I go to register my license file it tells me "the server is unavailable" ................................................................. 40
  4.2.3 When trying to register I get the error message "License check failed server returned 407 response code" ............................................................................................................ 40
  4.2.4 Error message when registering: "License Check Failed. Server Returned 302 Response code" ............................................................................................................. 40
  4.2.5 Error message "Server Response code 504" ................................. 40
  4.2.6 No more licenses are available for you to register ................. 40
  4.2.7 The license file I have received has an extension of .mim not .llv. I change it to .llv but still cannot register ................................................................. 41
  4.2.8 The requested URL_LocklizardLicensing_CheckLicense was not found on this server (displayed if a proxy is running) ................................................................. 41
  4.2.9 Can't connect to server www.locklizard-license.co.uk Error 12003. An extended error was returned from the server ................................................................. 41
  4.2.10 We cannot register your account because the server is not available ................................................................. 41
  4.2.11 An error has occurred while retrieving document access key. Unexpected end of file from server ................................................................. 41

  4.3 VIEWING PROTECTED PDFS ......................................................... 42
  4.3.1 Error message "You do not have the correct key that is required to decrypt this document" is displayed but you have been given access to the document ........................................................................................................ 42
  4.3.2 Error message "Acrobat could not open "<filename>.pdc" because it is either not a supported file type or the file has been corrupted" ........................................................................................................ 43
  4.3.3 Error message "You need to register with the publisher before you can view any protected documents" ........................................................................................................ 43
  4.3.4 Error 1284:68. Can't connect to server. Error 0. The server response could not be parsed. Please check your internet connection and try again ........................................... 43

  4.4 GENERAL FAQS ........................................................................ 44
  4.4.1 Do I have to be connected to the Internet in order to view secure PDF documents? ............... 44
  4.4.2 Where do I obtain a license to view protected PDF documents? ................................................................. 44
  4.4.3 What happens when I change or upgrade my computer - Do I need a new license? ............... 45
  4.4.4 How do I open a PDC document directly from Internet Explorer or any other browser? ... 45
  4.4.5 What is the remove keystore option for? ......................................................................................... 45
Chapter 1: Installation & Registration

1.1 Introduction

Safeguard Secure PDF Viewer enables you to view protected PDF files that have been published in .PDC format.

Safeguard Viewer is a standalone application that controls what you can do with protected PDF files (for example how long you can view them for, whether you can print them, etc.). These document controls are set by the publisher of the document and cannot be altered by yourself.

Safeguard Viewer can either be installed on your computer or run from a USB device. Only the publisher of secure documents can distribute USB devices containing the Viewer software, documents, and keystores.

All trademarks of Adobe Systems Incorporated are acknowledged, as are any other trademarks referenced in this manual.

1.2 Installation Pre-requisites

NOTE: Mac Installs

This manual only covers the installation of Safeguard Viewer on Windows platforms. For installation of Safeguard Viewer on Macintosh computers please refer to the Safeguard Macintosh OS X manual.

Safeguard viewer is compatible with the following Windows platforms (32 and 64 bit):

- Windows Vista
- Windows 7
• Windows 8
• Windows 10
• Windows Server 2003 and above

**IMPORTANT NOTE: INSTALLATION RIGHTS**

You must have Windows Administrator rights to install the viewer software. If you don’t have Windows Admin rights then you cannot install the viewer. Once the viewer software has been installed, then non-administrative (standard) Windows users can register and view protected documents.

**Users must have read/write rights to the following locations:**

C:\ProgramData\Locklizard\PDCViewer\

The keystore files are written to the All Users area of the computer and are therefore protected documents are available to all users of that computer.

### 1.3 Installing the Viewer

Make sure you are logged on as a Windows administrator with full privileges.

Double-click on the SafeguardPDFViewer.exe file in Windows Explorer to start the installation process. In Windows 7 and above, right-click on the SafeguardPDFViewer.exe file and select ‘Run as Administrator’.

The installation process is straight-forward and it takes less than a minute from start to finish.

Screenshots of the installation process are given below and are self-explanatory.
Diagram 1: Safeguard Viewer Setup Wizard

Diagram 2: License agreement

Diagram 3: Safeguard Viewer Installation folder
Diagram 4: Safeguard Viewer Installation Settings

Diagram 5: Safeguard Viewer Installation Confirmation

Diagram 6: Safeguard Viewer Installation complete
1.3.1 Firewall messages displayed during installation

During installation your firewall or anti-virus software may prompt you with the following (or similar) message window.

![ZoneAlarm Security Alert](Diagram 7: Firewall message window during installation)

During installation Safeguard Viewer prevents the process HKLD.exe from running which was used in previous versions of the Safeguard Viewer.

Check the box and select allow (or the equivalent for your product).
1.4 Installing the Viewer in Corporate Environments

1.4.1 Silent (remote) Installation

In corporate environments it may be a requirement that your IT department install applications programs and not you as the user.

Corporate IT departments often use system administration programs to remotely install software onto the desktop. These tools often do not process messages as an end user would have done because they will routinely specify the default settings for the system. To support IT department deployment we provide a silent installation mode to facilitate their ability to carry out automatic installs. As an end user you might also wish to use this facility in order to save time.

To run Safeguard viewer in silent installation mode without any dialogs displaying, the setup must be launched using the Windows Run command including the path to the install file and the "/S" parameter.

**Example:** "C:\Downloads\SafeguardPDFViewer.exe" /S

where C:\Downloads is the location of the Viewer installation file (exe).

1.4.1.1 Ini file and Install folder location

This command line option also has an optional INI file that can be passed containing session variable values.

**Example:** "C:\Downloads\SafeguardPDFViewer.exe" /S:<<optional ini file>>

For example:

"C:\Downloads\SafeguardPDFViewer.exe" "S:\C:\setupvariables.ini"

will cause the session variables in the INI file (setupvariables.ini) to be used for the setup. The INI file should be in the format:
[SetupValues]
%AppFolder%\=C:\Program Files\YourProduct

So in the example above with the custom ini settings passed at the command line, the Viewer will be installed in the "YourProduct" folder silently.

1.4.2 License File Registration (silent mode)

Once the viewer software has been installed in silent installation mode, you can register a license file from the command line (Windows Run command).

In the following examples, C:\InstallFolder is the location where the Viewer has been installed to and C:\Licensefiles is the location where the license file is located.

Example 1:
NO dialogs are displayed on successful registration

"C:\InstallFolder\PDCViewer.exe" "C:\Licensefiles\YourName.llv" /silent

Example 2:
Registration confirmation dialog is displayed on successful registration

"C:\InstallFolder\PDCViewer.exe" "C:\Licensefiles\YourName.llv" /s

IMPORTANT NOTE: Connection to the Internet is required

The license file will be registered with the Locklizard Administration server so an Internet connection is required, unless you have purchased Locklizard Safeguard as an own server solution running on your Intranet. You must have Windows Admin rights in order to register a license.
1.4.3 MSI Package

Safeguard viewer is also available as an MSI package so you can deploy it using Group Policy in your Windows enterprise environment.

The MSI package can be downloaded from the Locklizard web site:

http://www.locklizard.com/Downloads/SafeguardPDFViewer.msi

It is recommended that you disable Windows UAC and reboot the computer for these changes to take effect before installing the MSI package.

1.4.4 Disabling Automatic Updates

You may want to disable the auto update checker from running if your users are in a "locked-down" network environment and cannot install any software on their desktops. In such an environment, if a regular user attempts to update the viewer software then they will receive an error when the installation fails since the viewer software is unable to update the Windows registry.

Example of use - disable automatic update checks:
SafeguardPDFViewer.exe /UPDATE="0"

Example of use - enable automatic update checks:
SafeguardPDFViewer.exe /UPDATE="1"

NOTE: Manual Program Checks

Even if automatic update checks are disabled users can still manually check for updates using the 'Check for Program Updates' option on the Help menu.
1.5 Managing Proxy Settings

Proxy servers are used in some organizations to change the port addressing from the Windows default to another internally determined port number.

On some systems, because of internal security requirements, firewall controls are set to prevent internal applications from connecting directly to external web addresses. Further, to help prevent attacks from hackers, and prevent keyloggers and other programs commonly used by hackers, viruses and worms to send confidential internal data to outsiders, internal systems may use port addresses on the firewall that are not the standard ports. Finally, the firewall may require users who wish to use external services to authenticate themselves to the firewall before they are able to use external services.

To support these higher security requirements, Safeguard Viewer allows you to configure your proxy settings into the viewer.

Safeguard Viewer will automatically pick up current proxy information from Internet Explorer if it is available. However, if your proxy requires authentication, a dialog box will be displayed where you must enter the user name and password needed to authenticate yourself to the proxy.

![Diagram 8: Proxy authentication dialog](image)

Your internal IT department should be able to provide you with the necessary information.
There may be circumstances when you need to manually override these settings before you can register and use the viewer software.

To manually configure proxy settings right click on the Windows Start menu and select Programs > Safeguard PDF Viewer > Proxy Settings.

The following dialog is displayed.

![Proxy settings dialog](image)

Diagram 9: Proxy settings dialog

Here you can set the proxy from a configuration script or by manual entry.

### 1.5.1 Automatic configuration script

The viewer can be configured using a proxy administration PROXY.PAC file (a plain text file containing a JS function that will automatically configure the proxy settings to be used). In the ‘Address’ field, type in the full path of the Proxy.pac file you want to use (either an http:// path or a local file) and then press the **Load** button.

Below is an example proxy.pac configuration file that will make the viewer (or Internet Explorer) go via a local proxy server if a connection is made to www.locklizard.com:

```javascript
function FindProxyForURL(url, host)
{

```
if (shExpMatch(url, "http://www.locklizard.com*"))
    return "PROXY 192.168.1.1:8080";
else
    return "DIRECT";

1.5.2 Proxy server manual entry settings

To manually enter proxy settings, check the ‘Use proxy’ checkbox and then enter the address the proxy requires in the ‘Proxy address’ field. Your IT support group will be able to tell you the address you should enter here. Also, ask them if you need to enter a specific port address.

Safeguard Viewer uses port 443 to securely address (using HTTPS) the relevant administration server for the publisher whose product you have purchased (for internal systems this corresponds to the documents you are authorized to use). If your internal system requires the use of a different port for the connection you must enter it in the ‘Proxy port’ field.

The information for the server your publisher is using may be displayed in the license file and can be viewed with Windows Notepad or a similar application. If no port number is displayed then port 443 is used by default.

If your internal control system requires authentication at the firewall then check the ‘Proxy Authentication’ checkbox and enter in the fields provided the username and password that your IT department have allocated to access the firewall service.

If you do not supply the Proxy authentication data (username/password) but the proxy server requires authentication, a dialog box asking for the username and password will be automatically displayed when Safeguard Viewer tries to connect to the Internet.

If the "Use Proxy" check box is not checked, then the viewer will use the Internet Explorer settings for the Internet connection (assuming the proxy settings are defined in IE).
1.5.3 Proxy server installation settings

If you want to deploy the same proxy settings across multiple computers quickly then you can modify and deploy the Viewer ini settings file located at C:\ProgramData\Locklizard\PDCViewer\PDCViewer.ini

The ini file must contain the following settings (values below are provided as an example):

```
[Connection]
cType=1
ProxServ=192.168.1.1
ProxPort=999
```

Set cType=1, ProxyServ to the proxy address, and ProxPort to the proxy port number. This will instruct the Viewer to use the proxy settings on connection.

**NOTE:** PDCViewer.ini may be created by the setup or it may already exist on the user's computer. In your automation script you should add the above section if it doesn't already exist. Note that if you modify PDCViewer.ini before the Viewer is installed it could be overwritten and your custom proxy settings lost.
1.6 Registering the Viewer license

Before you can start viewing secure PDF documents you must first register your license with your publisher.

**IMPORTANT NOTE: Connection to the Internet is required**

You must be online to the Internet during the registration process because it updates the registration control service in real-time. If you do not have an Internet connection then you will receive an error message and you will have to start the process again.

You will have already been sent an email from your publisher containing your license file (safeguard_v_license.llv or YourName.llv) as in the example diagram below. The license file may be a link in the email and/or an attachment to the email in .llv and .zip formats.

![Diagram 10: Safeguard Viewer Registration Email](image)
1.6.1 Immediate Registration

To register, double-click on the .llv file in your email application (or select the download your license file link if available), select the ‘Open’ option, and then the OK button.

Double-clicking on the .llv file invokes the registration process and registers you with the publisher. A message dialog confirms successful registration.

1.6.2 Save license file and then Register

Alternatively, you can right-click on the license file attachment and use the ‘save as’ or ‘save to disk’ option to save the license file to disk. You can then double-click on the license file in Windows File Explorer to register.

1.6.3 Zipped license files and registration

The license file is also contained in a zip file so that it does not get stopped or altered by firewalls, or corrupted by mail applications during transmission.

If you cannot register using the .llv license file for any reason then use the one contained in the zip file.

Double-click on the zip file in your email application, select the ‘Open It’ option, and then the OK button. Then double-click on the .llv file (this file is revealed when the unzip process has run).

---

**NOTE: Firewalls may rename file extensions**

Some firewall products may have renamed the zip file, and you may have to approve running it to reveal the license file contents. Zone Alarm for example, renames zip files with a .zm9 file extension. You can either double-click on this file and Zone Alarm will run asking you whether you want to view the contents, or you can save the file to disk, rename the file extension back to .zip, and then double-click on it.
1.6.4  Web based email systems and registration

With web based email systems (where you view your emails through a web browser) you will need to save the license file to disk before double-clicking on it so that the license process can be executed locally.

1.6.5  Successful Registration

At registration time checks are made to see if your customer account exists, when it becomes valid, and the documents / publications you are allowed to access. Once you have successfully registered, this dialog is displayed:

![Diagram 11: Successful registration message](image)

You will now be able to view documents and publications you are licensed for.

If you are not connected to the Internet at the point of registration then you will receive an error message and you will have to start the process again.

**IMPORTANT NOTE:** Backup your license file

Please make sure you retain a copy of the license file in case you need to recover the system after a disk crash, or when updating to a new system, when you will need to register your license again.
1.6.6 Registration issues and firewalls

Safeguard Viewer uses port 443 (standard HTTPS port) to securely address (using HTTPS) the relevant administration server for the publisher whose product you have purchased. You must therefore make sure that if your company has a hardware firewall in place, or you are running a software firewall, that port 443 is opened.

The information for the server your publisher is using may be displayed in the license file and may be viewed with Windows Notepad or a similar application. If no URL is displayed in the license file, the system is using either port 443 (the default) or port 80. You will need to contact the publisher of the document if you cannot register on either port, since they may be using an own server environment which uses different port numbers.

1.6.7 Firewall messages displayed during registration

Some firewalls or anti-virus products may display the following message window (or similar) during registration. This notifies you that Safeguard Viewer is trying to access the Internet.

![ZoneAlarm Security Alert](image)

Diagram 12: Firewall message window during registration
You must check the box (remember this setting) and select the Allow button (or the equivalent for your product) so that the viewer can connect to the Internet and register your license.

The viewer will also need to connect to the Internet when you view a document for the first time, and may need to connect on subsequent occasions depending on the document controls set by the publisher.

1.6.8 Registering with a publisher more than once

The license file given to you by your publisher may be valid for installation on one or several computers. If it is only valid for one installation then once you have registered using that license file it cannot be used again.

You can, however, re-use your license file more than once on the SAME computer. For example, if you have had to remove your viewer keystore then you can re-register using the original license file from your publisher.

If you have purchased multiple documents and entered different user information each time (for example, John Doe the first time and J Doe the second time) then you will be sent a new license file. You will need to register using this second license file so that you can access any documents that you purchased with the second user name.

However, if you purchased multiple documents from and always entered the same user information each time, then you will only need to register once. You will automatically have access to all protected documents you have purchased.

1.6.9 Registering with different publishers

If you have purchased protected documents from different publishers you will need to get a viewer license from each publisher before you can access their document(s). You do not need to install the viewer software again.
1.6.10 Messages displayed if you have not registered

If you try to view a protected PDF file before you have registered, the following dialog box (or similar) is displayed.

Diagram 13: Registration required dialog
Chapter 2: Viewing Protected PDF Files

To view a protected PDF file (PDC file), double-click on it in Windows File Explorer.

The protected PDF file is decrypted and displayed in the Safeguard Viewer. As an example, you might see something like this:
When you view a secure PDF document (PDC file) for the first time, the viewer software will check if it has the correct key to view it. If it does not, the viewer will check with your publisher’s administration server to see if you have been granted access to the document (you MUST be connected to the Internet at this point). If access is allowed then the decryption key is transparently relayed from the publisher to the viewer and you will be able to view the document. If not, a message will be displayed telling you how to contact the publisher in order to be granted access to the document.

2.1 Firewall / anti-spyware messages displayed when viewing documents

The first time you view a protected document your firewall / anti-spyware product may display the message (or a similar one) below.

Diagram 16: Software firewall message dialog
Safeguard Viewer does NOT monitor mouse activity, characters entered, web sites visited etc., on your computer. It just checks whether its own processes are running and you have to allow it to do this in order to view protected documents.

Check the box (apply this setting to all suspicious behaviors exhibited by this application) and select the Allow button.

**NOTE: Firewall Settings**

If you select the Deny button then the viewer window will be minimized and the protected document will not be displayed.

### 2.2 Viewer controls

Safeguard Viewer uses familiar document controls so you can simply navigate your way around a document. Less familiar controls are explained below.

#### 2.2.1 Searching for text

This option can be found from the Document > Find Text menu item or from the icon in the toolbar. **NOTE:** The find dialog can be resized.

![Diagram 17: Find dialog box](image)
If you want a list of the search results, select the ‘Show search results dialog’ checkbox (the default setting). When the search has finished the following dialog box will be displayed where you can select from individual instances of the word you are searching for.

![Find results dialog](image)

Diagram 18: Find results dialog

### 2.2.2 Page up / down controls

![Page controls](image)

You can navigate around a document by using the:

1. Page controls in the toolbar;
2. Page controls down the right-hand bottom side of the viewer scroll bar;
3. Scrolling with your mouse;
4. Page up/down keys on your keyboard.

These controls are also available from the Document menu.
2.2.3 Document display size (zoom)

You can change the document display size in the toolbar by:

1. Selecting the minus or plus buttons;
2. Selecting a value from the pull-down list box;
3. Entering a custom value directly into the field. If you enter a value into the field then you must press the enter button on your keyboard in order for it to take effect.

The document display size can also be altered using the Zoom options off the View menu.

**Keyboard controls:** In both full screen and normal mode you can use the + and – buttons on the numeric keypad section of your keyboard to zoom in and out of a document.

2.2.4 Navigation buttons

History navigation buttons (next and previous buttons) are available on the toolbar and the vertical scrollbar. These are useful to use if the documents you are viewing have links in them to other pages. Once you have pressed on a link you can then use the previous button to go back to the page you were previously viewing. The history cache will hold a maximum of 50 viewed pages.

2.2.5 Scrolling options

By default documents are displayed in continuous scrolling mode. If you want to scroll one page at a time then select the Single Page option from the View > Page Layout menu.
2.2.6 Viewing multiple pages (book format)

If you want to view pages side by side (just like in a book) then select the Page Layout > Facing option from the View menu.

You can adjust the document display size until you see the pages fully on the screen.

2.2.7 Menu bar display

If you have unchecked the view menu bar option and the toolbar option and would like the menu bar to re-appear then press the escape key (ESC) on your keyboard.

2.2.8 Full screen mode

The combination keys Ctrl+L can be used to switch between full screen mode and normal mode.

This option is also available from the View menu and by pressing the button on the task bar.

1. **Printing**
   Whilst in full screen mode, Ctrl+P can be used to display the print dialog (but only if printing has been allowed).

2. **Searching for text**
   Ctrl+F can be used to display the find (search) dialog.

3. **Zooming in & out of a document**
   You can use the + and – buttons on the numeric keypad section of your keyboard to zoom in and out of a document.
2.2.9 Printing Controls

Diagram 19: Print dialog

2.2.9.1 Print Range

The print range pages edit box may contain any of the following:

1. a page range: e.g. 2-50
2. a single page number: e.g. 23
3. multiple page ranges: e.g. 2-50;65-90;110-135
4. multiple single pages: e.g. 23;34;45;67
NOTE: Semicolon Spacers

Multiple page ranges and page numbers MUST be separated by a semicolon.

The print range edit box will only accept:

1. numbers: 0 to 9
2. the minus sign: -  page range separator
3. semicolon: ;  for distinguishing multiple ranges/pages

NOTE: Character separators

All other characters will be ignored including the comma as a separator.

The following example shows what you should enter in the page range edit box to print the first 10 pages, the last 10 pages, and page 25 of a 210 page document: 1-10;200-210;25

There is no special order between a single page and a page range, meaning that they can be mixed. For example: 1-10;23;24 or 23;1-10;24. The only difference between these two selections is the order in which the pages are printed.

2.2.9.2 Print Range: Current View

Selecting this option will print the area you have currently zoomed into.

2.2.9.3 Fit Contents to Page

Selecting this option (the default) will make the view display match the printed output with left/right and top/bottom margins adjusted accordingly.
2.2.9.4  Auto-rotate

Select this option (the default) if you have both portrait and landscape pages in the same document. Landscape pages will be automatically rotated to fit.

2.2.9.5  Preview

This shows how the document will print.

If the Preview pane shows the document in black & white or greyscale for a color document, then this setting has been enforced by the publisher and cannot be changed.

### NOTE: Disabled Printing

If printing is disabled the print button will be shown as and the button will be deactivated.

2.2.10  Opening Documents at last viewed page

If you are viewing a large document and would like the viewer to open the document at the last viewed page then select the option ‘Remember Last Page Viewed’ from the Document menu. The viewer will next open the document at the page that was last displayed when the document was closed.

You can deselect the ‘Remember Last Page Viewed’ option from the Document menu if you no longer want this feature enabled.

2.2.11  Saving Settings

If you change the document page layout (single page, continuous, facing), zoom level, or page size (fit to width, fit to page, actual size), the viewer will apply these settings to the next document you open.
2.3 **File Sizes supported**

Safeguard Viewer supports files of up to 200Mb in size.

Since files are decrypted in memory file opening times will depend on your computer environment.

Examples of expected timings for very large file size handling are given below.

<table>
<thead>
<tr>
<th>CPU</th>
<th>O/S</th>
<th>Memory</th>
<th>File size</th>
<th>Load time</th>
</tr>
</thead>
<tbody>
<tr>
<td>P4 3.4 GHz</td>
<td>Win XP Pro</td>
<td>1 Gb</td>
<td>200 Mb</td>
<td>30 seconds</td>
</tr>
<tr>
<td>Celeron 1.3</td>
<td>Win XP Pro</td>
<td>512 Mb</td>
<td>200 Mb</td>
<td>4.5 minutes</td>
</tr>
</tbody>
</table>

These are not guaranteed timings but guidelines so that you have an indication of anticipated opening times when attempting to handle very large scale protected files, and the impact on slower machines or lower memory systems.

2.4 **Program Updates**

Once a week, Safeguard Viewer will check with the Locklizard Administration server to see if any new updates are available. If updates are available, the Viewer software will ask you whether you want to download and install the new updates.

You can also check for updates on a more regular basis by using the ‘Check for Program Updates’ option from the Help menu.

**NOTE: Windows User Rights**

In order to install any updates you will need the appropriate Windows user rights to update the Windows Registry and the Safeguard Viewer program installation folder.
2.5 **Document controls**

The publisher may have placed controls on the document that require you to connect to the Internet whenever you want to use a document, or connect occasionally, and the viewer will automatically enforce those controls.

The publisher may only have licensed you to view a document for a specific number of times. If that is the case you must be connected to the Internet in order to view the document.

The publisher may have imposed additional screen grabber limitations. If this is the case screen grabs will either be prevented (and you will be asked to close your screen grabber application) or screen grabs will result in a black image. A screen mask may also be applied when mouse focus is removed from the viewer window as shown in the diagram below.

![Screen mask](image-url)
You may or may not be able to print a document (the print icon therefore may or may not be enabled) and/or printing may be limited to a number of copies.

If printing is disabled the print icon will be shown as 📑.

When you print a document a watermark image or text may be displayed on the printed document.

Details of when your account expires (if ever) and when the document you are viewing expires (if ever) are displayed at the bottom of the viewer window in the status bar.
Chapter 3: USB Secure Viewer

This chapter describes the additional features available in the USB version of the Viewer. These apply only if your publisher has published the Viewer software, keystore and documents to a USB device. You (the end user) are not able to initialize a USB stick for these purposes.

⚠️ **NOTE:** You do not need to install or register the Viewer software if it has been supplied on a USB device.

### 3.1.1 Opening Secure Documents

#### 3.1.1.1 Using the Autorun application

In order to view and open secure documents on a USB device, double-click on the file Autorun.exe. This will open up a dialog with a list of the PDC documents available on the USB device.

![Diagram 21: USB Details](image)

You can either click on a secure document and press the button, or double-click on a document to open it.
3.1.1.2 Associating the Viewer software with PDC files

Alternatively, you can right-click on a PDC file and select ‘Open With’ > ‘Choose Default Program’, and then Browse for the Safeguard PDF Viewer application (pdcviewer.exe) on your USB device. This can be found in the Viewer folder.

You will then be able to open subsequent secure documents by double-clicking on them.

3.1.2 Proxy Settings

The Proxy Settings option is now available from the File menu.

3.1.3 Keystore Password Protection

Since USB devices are portable they can be easily lost or stolen, users have the option of setting a password to prevent misuse of the contents by others. If a password has been set, then it has to be entered before a secure document can be opened.

3.1.3.1 Set Password

To set a password, select the ‘Set USB Password’ option from the File menu.

![Diagram 22: Keystore Password](image_url)
IMPORTANT NOTE: Make sure you make a note of the password as there is no way to recover the password if it is lost/forgotten. You will not be able to open secure documents or remove your keystore if you forget it.

3.1.3.2 Change or Remove Password

To change the password, select the ‘Set USB Password’ option from the File menu. You will be asked for the current password, and if entered correctly, you can then enter your new password.

To remove the password leave the passwords fields empty and press the OK button.

3.1.4 Remove Keystore

The Remove Keystore option is now available directly from the File menu. It will create a blank keystore that remains registered to the publisher account that created it. After the keystore has been removed the Viewer will have to connect to the relevant administration server when opening secure documents for the first time in order to retrieve their decryption keys.

NOTE: If a keystore password has been set you will be asked to enter the password before the keystore can be removed.

3.1.5 USB ID

The publisher of the secure documents may ask you for the ID of the USB device you are using so they can assign additional access rights. The actual USB ID is displayed in the far right of the status bar (bottom of the Viewer window).

<table>
<thead>
<tr>
<th>Account: never expires</th>
<th>Document: never expires</th>
<th>USB: 12052080000542</th>
</tr>
</thead>
</table>

Diagram 23: USB ID
It is displayed when the Viewer on the USB is running regardless of whether a document has been opened or not. To run the Viewer without opening a document, navigate to the Viewer folder on your USB device and double-click on the application PDCViewer.exe. (You may need to do this if a USB device was published with a blank keystore.)

3.1.6 Program Updates

The Viewer update facility should not be used as it installs the Viewer software on the user’s computer rather than updating the USB device. Later versions of the Viewer will update the USB device automatically.
Chapter 4: Troubleshooting

This chapter covers error messages that may be encountered when you are using Safeguard Viewer. This is split into four main areas: Installation, Registration, Opening a Document and General FAQs.

An online knowledgebase system can be accessed at http://locklizardkb.com. This contains the latest troubleshooting information.

IMPORTANT NOTE – CONTACTING SUPPORT

If you encounter an error that is not detailed in this section then please contact your publisher for support. Do not contact Locklizard support directly as you will be referred back to your publisher.

Please use the ‘Contact Service Support’ option from the Help menu wherever possible so that important version and machine details are given to your publisher.

4.1 Installation

4.1.1 When I go to install the viewer by double-clicking on the exe file, it tells me the file is corrupted

This error message is displayed if you have not downloaded the complete file. Delete the partially downloaded file and re-download the software. Once you have done that, check the file size published on the web site and compare it with the one you have locally on your disk to make sure it is the same.
4.2 Registration

4.2.1 Error Message “We cannot connect to the license server by Internet. Please check that you are connected, or that a firewall is not stopping this connection.”

This error message will be displayed if either a firewall or proxy is stopping the Safeguard Viewer from getting to the Internet.

If you are behind a company firewall then your IT department may have to configure the firewall to accept an outbound connection for the viewer program pdcviewer.exe on the appropriate port and allow access to the Locklizard licensing server.

NOTE: Software Firewall

If you decide to disable your software firewall to register the viewer software then remember you must reboot your computer before it will take effect (software firewalls remain memory resident even after you disable them).

In the case of proxy servers, proxy settings are automatically picked up from Internet Explorer by the viewer software but there may be occasions when this information is incorrect or unavailable and you will have to manually enter proxy settings in Safeguard viewer.

Off the Windows Start menu > Programs > Safeguard PDF Viewer > Proxy Settings is where you enter this information. See proxy settings.

Once you have registered the viewer it does not need the proxy settings again unless someone decides to change your internal proxy settings.
4.2.2 When I go to register my license file it tells me “the server is unavailable”

Please try registering again. If the problem continues then the most likely reason for this is that you are using a proxy to access the Internet. Make sure you have entered the correct proxy settings and then try again. See proxy settings.

4.2.3 When trying to register I get the error message “License check failed server returned 407 response code”

The most likely reason for this is that you are using a proxy to access the Internet. Make sure you have entered the correct proxy settings and then try again. See proxy settings.

4.2.4 Error message when registering: “License Check Failed. Server Returned 302 Response code”

This message is displayed when the URL for the licensing server is redirected by a proxy server. The most common reason for this message is that your organization strictly controls access to web sites and the Locklizard Licensing server has not been added to the authorized list.

4.2.5 Error message “Server Response code 504”

This error message is displayed if port access is blocked. Safeguard Viewer needs the port specified in the license file open so it can communicate with the server. Please check with your company’s network engineers that this port is open.

4.2.6 No more licenses are available for you to register

This error message is displayed if you don’t have any licenses left to register with. You need to go back to the company you purchased the protected document/ebook from to request an additional license. Locklizard cannot provide licenses on behalf of publishers using our software since we do not have access to their systems.
4.2.7  The license file I have received has an extension of .mim not .llv. I change it to .llv but still cannot register.

This is because you are using AOL or IM as an email client and AOL / IM has corrupted the license file and changed the file extension.

Use the .llv file contained in the zip file instead. Save the zip file to disk, unzip it and then double-click on the .llv file.

4.2.8  The requested URL_LocklizardLicensing_CheckLicense was not found on this server (displayed if a proxy is running)

4.2.9  Can’t connect to server www.locklizard-license.co.uk Error 12003. An extended error was returned from the server.

4.2.10 We cannot register your account because the server is not available

The most likely cause for these error messages is that access to port 443 is blocked. Outbound and inbound traffic must be enabled on this port.

If your network administrator does not allow traffic on this port then you can use port 80 instead. To do this, paste the license link into your browser and change the https to http. If you have received the license file as an attachment then you need to ask the company that sent you the license file for an HTTP version.

Before you attempt to register again with HTTP, use the ‘Remove Keystore’ option from:

Windows Start menu >> All Programs >> Locklizard >> Safeguard >> Viewer >> Remove Keystore.

If using HTTP does not work then check with the publisher as to what port is being used. The default is port 443, but some publishers may be using own server systems that use different port numbers.
4.2.11 An error has occurred while retrieving document access key. Unexpected end of file from server.

The most likely reason for this is that the viewer is losing packets due to a poor or inconsistent Internet connection. If this is the case you will need to check your connection and retry when it is stable.

4.3 Viewing protected PDFs

**IMPORTANT NOTE: Print Screen**

When the viewer is running Windows print screen is disabled by default and cannot be used by any programs whilst the viewer remains active.

If you are running a ‘screen grabber’ application you may be asked to close it whilst the viewer remains active.

4.3.1 Error message “You do not have the correct key that is required to decrypt this document” is displayed but you have been given access to the document.

The most likely reason for this error message is that the file is incomplete (partial download). Please compare the file size of the PDC file against the file size listed on the publisher’s server. If this information is not available then please ask your publisher for it.

If the file size is incorrect then you will need to re-download the PDC file.
4.3.2 Error message "Acrobat could not open "<filename>.pdc" because it is either not a supported file type or the file has been corrupted"

This error message is displayed if you try and open a .pdc file directly from Adobe’s File Open menu or you have associated the .pdc file extension with Adobe Acrobat.

To open a .pdc file you must double-click on the filename in Windows File Explorer or right-click on the file and select ‘Open With PDCViewer’. Alternatively, you can open a PDC file from the Safeguard Viewer File Open menu.

4.3.3 Error message "You need to register with the publisher before you can view any protected documents"

Before you can view protected documents you must first double-click on the license file sent to you by your publisher in order to register.

If you have done this and this message still appears then the most likely reason is that you tried to register the viewer software over a VPN which will not work - you MUST have a direct Internet connection.

Delete the keystore (off the Windows Start menu select Programs > LockLizard > Safeguard > PDF Viewer > Remove Keystore) and then try registering again, this time using a direct connection to the Internet.

4.3.4 Error 1284:68. Can't connect to server. Error 0. The server response could not be parsed. Please check your internet connection and try again

This message is displayed if the server response is truncated (the data sent from the server gets corrupted). This could be because:

1) The license file has been corrupted. Obtain a new license file from your publisher or register using the one contained in the zip file.
registering again you will need to delete your keystore (off the Windows Start menu select Programs > LockLizard > Safeguard PDF Viewer > Remove Keystore). Once you have done this double-click on the license file to register.

2) A proxy is in use and proxy settings have not been configured in the viewer software. See proxy settings.

4.4 General FAQs

4.4.1 Do I have to be connected to the Internet in order to view secure PDF documents?

This depends on the controls set by the publisher. They may require that you connect to the Internet every time you view one of their documents, or that you connect every n number of days, or that you don’t need to connect to the Internet at all.

If the publisher has limited the number of times you can print a document then you will be required to connect to the Internet each time you attempt to print.

4.4.2 Where do I obtain a license to view protected PDF documents?

Contact the relevant publisher (the company or person that supplied the protected document). If you do not have a license for a .pdc file the viewer will display a message from the publisher telling you how to contact them.
4.4.3 What happens when I change or upgrade my computer - Do I need a new license?

If you change computers or upgrade your computer with a new hard disk then you will need to ask your publisher for another license so that you can install the viewer software and register again.

4.4.4 How do I open a PDC document directly from Internet Explorer or any other browser?

If you click on a link to a PDC file from Internet Explorer, you are asked to Open or Save the file. To view the document, select the Open option. Internet Explorer will then call the Safeguard viewer to display the PDC file. To get Internet Explorer to automatically call the viewer to display the PDC file every time you click on a PDC file link, uncheck the option "always ask me before opening this type of file".

4.4.5 What is the remove keystore option for?

On rare occasions, security information may be corrupted, and it is necessary to regenerate that information. To cause this to happen you use this feature to remove the existing faulty keystore, and then re-register your license with your publisher.

The remove keystore utility is located in the Locklizard Safeguard Viewer program group off the Windows start menu – Start > All Programs > Locklizard > Safeguard > PDF Viewer > Remove Keystore.